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1 Minimum system requirements

Operating system 32 bit version of:

￭ Windows 2000 SP4
￭ Windows XP Professional SP2
￭ Windows Vista Business / Enterprise / Ultimate
￭ Windows 7 Professional / Ultimate / Enterprise

64 bit version of:

￭ Windows 7 Professional / Ultimate / Enterprise

RAM Windows 2000 / Windows XP: 1 GB

Windows Vista, Windows 7: 2 GB

Memory Program: 1 GB

Data: 2 GB

Serial ports for devices with RS-232 interface

USB ports for devices with USB interface

Screen Resolution 1024 x 768

The windows user must have administrator rights in order to be able to install
the MagIC Net software.

Additional requirements for the MagIC Net server:

Operating system 32 bit version of:

￭ Windows 2000 SP4
￭ Windows XP Professional SP2
￭ Windows Vista Business / Enterprise / Ultimate
￭ Windows 7 Professional / Ultimate / Enterprise
￭ Windows 2000 Server
￭ Windows Server 2003
￭ Windows Server 2008
￭ Windows Server 2008 R2

64 bit version of:

￭ Windows 7 Professional / Ultimate / Enterprise
￭ Windows Server 2008 R2
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Network 10 Mbit/s, stable and permanent

Communication via TCP/IP

Caution

During a determination data loss may occur when the PC switches over to
the standby mode. In the energy settings of the operating system the
standby mode should therefore be deactivated.

2 Single workplace installation

With the single workplace version MagIC Net Basic, MagIC Net Compact
or MagIC Net Professional the MagIC Net client as well as the server will be
installed on your computer.

1 On inserting the CD into the drive of your computer the installation will
be started automatically. If this option is deactivated on your computer,
double click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nevertheless.

Afterwards, click on [Next].

 

2 After having read the license agreement for MagIC Net and accepted it
with [Yes], a window will appear where you can enter the license code.

 

3 Enter the license code for MagIC Net Basic, MagIC Net Compact or
MagIC Net Professional and click on [Next].
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Note

If you have entered the license code of an update license, then the
license code of the previous full version will additionally be requested.

 

4 Now enter the target folder for the MagIC Net installation and confirm
with [Next].

 

5 In the dialog window Additional installation information you can
define the paths for the database and backup files:

Note

The default paths may differ depending on the Windows version used.
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Under [Advanced...] it is possible to change the ports MagIC Net uses
to communicate with the database and administration server. If the ports
are already used, an appropriate error message will appear. Ask your sys-
tem administrator for more information about this. Continue with [Next].

 

6 Follow the instructions of the program until the following message
appears:

This message points out which ports MagIC Net uses. Write down these
ports and inform your system administrator in case MagIC Net is not
able to connect to the database. Confirm the message with [OK].

 

7 As soon as the copying procedure has been finished you can set further
workplace settings:

The option "The client ID must exist in the current MagIC Net sys-
tem." can only be activated if a database from a previous installation
already exists on your computer or if you want to connect to a database
server installed on another computer.

If you activate this option MagIC Net checks whether the identifier you
have entered exists in the database. If this is true the identifier and all
associated settings will be adopted. With this option reinstalling a client is
much easier.

Click on [Next]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.
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8 At the end of the installation, the file info.txt will be created which con-
tains all relevant information concerning your current MagIC Net installa-
tion. Save this file on your hard disk in case of need in future and print it
(add to IQ). Complete the installation with [Finish].

An InstallLog file with a list of all files having been copied to your com-
puter and with a confirmation of a successful installation is saved in the
MagIC Net installation folder (default: C:\Program Files\Metrohm
\MagIC Net) under bin\InstallLog.

3 Client/Server installation

With the MagIC Net Multi version (multiple workplace version with 3 licen-
ses) you can select during the installation whether you want to install a
MagIC Net client or the MagIC Net client plus server on your computer.

If you want to install a MagIC Net client only on your computer, a server, to
which the client will be connected, must have been previously installed on
another computer.

1 On inserting the CD into the drive of your computer the installation will
be started automatically. If this option is deactivated on your computer,
double click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nonetheless.

Afterwards, click on [Next].

 

2 After having read the license agreement for MagIC Net and accepted it
with [Yes], a window will appear where you can enter the license code.

 

3 Enter the license code for MagIC Net Multi and click on [Next].
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Note

If you have entered the license code of an update license, then the
license code of the previous full version will additionally be requested.

 

4 Now enter the target folder for the MagIC Net installation and confirm
with [Next].

 

5 The dialog window Additional installation information appears
where you can select whether you want to install a client or the server:

The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.

With Client, only the client will be installed and you have to select the
database server (has to be installed in advance!), to which you want to
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connect, with . The network server name or the IP address are accep-
ted.

Under [Advanced...] it is possible to change the ports MagIC Net uses
to communicate with the database and administration server. If the ports
are already used, an appropriate error message will appear. Ask your sys-
tem administrator for more information about this. Continue with [Next].

 

6 All further installation steps correspond to those of the single workplace
installation on from point 6.

4 Modify / repair / remove installation and upgrade
license

In order to carry out modifications on the current MagIC Net installation, start
the file setup.exe on the installation CD or click on Metrohm MagIC Net
under Control Panel ▶ Software. Then select Change/Remove:

Modify

With this option you can change the paths to the database and backup files
and set the ports which MagIC Net uses for communication. With the
MagIC Net Multi version you can additionally change the path to the data-
base server.

If the database path is changed, the existing databases are automatically cop-
ied to the new location.

Repair/Update

With this option you can repair an existing defective installation or update an
older installation.
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￭ Repair installation
In case of a defective MagIC Net installation due to e.g. a missing DLL file
or an accidentally deleted program file, MagIC Net can be repaired with
this option.

￭ Update installation
In case an older version of MagIC Net is installed, it will be updated to the
new version of MagIC Net, see Program update with MagIC Net Com-
pact/Professional or Program update with MagIC Net Multi.

Caution

During updating older MagIC Net versions to MagIC Net 2.x the databases
will be converted to the new version. Depending on the size of the data-
base, this can take some time. For each database a progress bar is displayed
which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long as
the conversion is running!

License upgrade

Allows a direct upgrade of your current installation to a MagIC Net version
with additional features. The following upgrade paths are possible:

￭ MagIC Net Compact to
MagIC Net Professional or MagIC Net Multi

￭ MagIC Net Professional to
MagIC Net Multi

In order to do this, enter your new license code in the next dialog window.

Remove

This option removes your MagIC Net installation. Data which has been gener-
ated after the installation (e.g. database entries, log files, exported data etc.)
will remain on your hard disk.

5 Program update with MagIC Net Compact/Pro-
fessional

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically upda-
ted for further use with MagIC Net Compact/Professional.
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Note

The files in the database and backup directory will be retained when updat-
ing the program.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories, which have not been
overwritten by the update, will be deleted. The deleted files are listed in the
InstallLog.

1 Save the configuration database into an external directory using the
backup function of MagIC Net. In the program part Configuration,
select the menu item File ▶ Save ▶ Manually. Select the Backup direc-
tory, enter a name for the backup file and click on [Start]. The backup is
carried out automatically. It is recommended to copy the backup file to
CD/DVD.

 

2 If desired, export the methods in addition to the automatic backup of the
configuration database (see above) into an external directory. In the pro-
gram part Method, select the menu item File ▶ Method manager....
Select the desired Method group, mark all methods to be exported and
click on [Edit] ▶ Export.... Select the desired export directory and click
on [OK]. The methods are exported into the desired directory. It is recom-
mended to copy the exported methods to CD/DVD.

 

3 Save all determination databases created by yourself into an external
directory using the backup function of MagIC Net. In the program part
Database, select the menu item File ▶ Database manager.... Select
the desired database and click on [Backup]. Select the Backup direc-
tory, enter a name for the backup file and click on [Start]. The backup is
carried out automatically. It is recommended to copy the backup file to
CD/DVD.

 

4 Save further files created by yourself in the installation directory (e.g.
export files) into an external directory or to CD/DVD.

 

5 Close MagIC Net. Insert the installation CD and double click the file
setup.exe. Then select Repair/Update and click on [Next].
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6 Enter the update license code for MagIC Net Compact or MagIC Net
Professional and click on [Next].

 

7 Caution

During updating older MagIC Net versions to MagIC Net 2.x the data-
bases will be converted to the new version. Depending on the size of
the database, this can take some time. For each database a progress
bar is displayed which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long
as the conversion is running!

Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to your com-
puter and with a confirmation of a successful installation is saved in the
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MagIC Net installation folder (default: C:\Program Files\Metrohm
\MagIC Net) under bin\InstallLog.

6 Program update with MagIC Net Multi

During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the sever are automatically updated for further use with
MagIC Net Multi.

Note

The files in the database and backup directory will be retained when updat-
ing the program.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories, which have not been
overwritten by the update, will be deleted. The deleted files are listed in the
InstallLog.

1 Make sure MagIC Net Multi is closed on all clients.

Note

In the subdirectory bin of the MagIC Net installation, you will find the
application Clients.exe, with which all clients and their status can be
displayed.

 

2 Open MagIC Net Multi on the server and save the configuration data-
base into an external directory using the backup function of MagIC Net.
In the program part Configuration, select the menu item
File ▶ Save ▶ Manually. Select the Backup directory, enter a name
for the backup file and click on [Start]. The backup is carried out auto-
matically. It is recommended to copy the backup file to CD/DVD.

 

3 If desired, export the methods in addition to the automatic backup of the
configuration database (see above) into an external directory. In the pro-
gram part Method, select the menu item File ▶ Method manager....
Select the desired Method group, mark all methods to be exported and
click on [Edit] ▶ Export.... Select the desired export directory and click
on [OK]. The methods are exported into the desired directory. It is recom-
mended to copy the exported methods to CD/DVD.

 

4 Save all determination databases on the server into an external directory
using the backup function of MagIC Net. In the program part Data-
base, select the menu item File ▶ Database manager.... Select the
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desired database and click on [Backup]. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is car-
ried out automatically. It is recommended to copy the backup file to CD/
DVD.

 

5 Save further files in the installation directory (e.g. export files) into an
external directory or to CD/DVD.

 

6 Update server

Close MagIC Net Multi on the server and on all clients. Insert the instal-
lation CD on the server and double click the file setup.exe. Then select
Repair/Update and click on [Next].

 

7 Enter the update license code for MagIC Net Multi and click on [Next].
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8 Note

The update of MagIC Net Multi consists of the server license and
three client licenses. If an existing installation contains additional licen-
ses, these will be deleted.

Click on [OK] in the corresponding message in order to continue the
installation.

 

9 Caution

During updating older MagIC Net versions to MagIC Net 2.x the data-
bases will be converted to the new version. Depending on the size of
the database, this can take some time. For each database a progress
bar is displayed which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long
as the conversion is running!

Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to the server
and with a confirmation of a successful installation is saved in the
MagIC Net installation folder (default: C:\Program Files\Metrohm
\MagIC Net) under bin\InstallLog.

 

10 In case additional licenses have been removed during the server update,
or if further additional licenses are to be added, the Administrator can
enter them in MagIC Net (dialog: Configuration ▶ Tools ▶ Program
administration ▶ Licenses ▶ Add licenses).

 

11 Update clients

For each client, insert the installation CD and double click the file
setup.exe. Then select Repair/Update and click on [Next]. Complete
the installation with [Finish].

Note

In order to facilitate updating many clients, the installation can be cop-
ied from the CD to a writeable medium and the file magic_init.ini can
be modified. There, user-defined parameters (license code, installation
path, server name, ...) for the installation can be set in advance, which
allows you to only having to click through the installation.

An UpdateLog file with a list of all files having been copied to the client
computer and with a confirmation of a successful installation is saved in
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the MagIC Net installation folder (default: C:\Program Files\Metrohm
\MagIC Net) under bin\InstallLog.

7 Installation of drivers

The installation routine of MagIC Net usually automatically installs all the driv-
ers necessary for controlling the supported devices.

If you are using a 64 bit operating system it may be necessary to install drivers
manually in combination with a few devices. This is the case if the operating
systems displays a message when connecting a device to the computer, e.g.
Device driver software was not successfully installed. No driver
found. The message should also show the name of the corresponding device.
Note this name and proceed as follows to install the driver manually:

Note

The following description applies for Windows 7 (64 bit version). It may
slightly vary for your system.

1 Open the Windows Device Manager. Under Other devices the corre-
sponding device can be found.

 

2 Click on the device with the right mouse button. The context menu
opens.

 

3 In the context menu, select Update Driver Software.... A dialog win-
dow opens.

 

4 Select Browse my computer for driver software. The file selection
dialog opens.

 

5 Navigate to the installation folder of MagIC Net (default: C:\Program
Files\Metrohm\MagIC Net).

 

6 In the installation folder, open the subfolder drivers. It contains a sub-
folder for each of the corresponding devices, containing the necessary
driver.

 

7 In the subfolder drivers, open the subfolder of the corresponding device
and select the driver file (*.inf).

 

8 Apply the selection with [OK]. A safety prompt is displayed. In order to
install the driver, click on [Install].

 

9 After the successful installation, close the Device Manager.
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8 Adding additional licenses with Windows Vista
or newer

General

Since Windows Vista, Microsoft has introduced the UAC (User Account Con-
trol), which permits running tasks either as non-administrator or as administra-
tor (without changes of user, switching off or similar).

http://technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx

http://technet.microsoft.com/en-us/magazine/2007.06.uac.aspx

This function can however cause difficulties with client/server installations for
MagIC Net.

Problem description

One would like to add additional licenses for the program; the license code for
an additional 5 licenses, for example, is added (on the server) in the program
part Configuration in the dialog window Program administration (accessi-
ble via menu item Tools ▶ Program administration, tab Licenses).

The file license.mlic, which contains the standard license code and the addi-
tional license codes, is stored in the bin directory of the program installation
(C:\Program Files\Metrohm\MagIC Net\bin).

If one adds the 5 licenses and then looks at this file license.mlic, only the
standard license code will be listed (for 3 licenses).

If one highlights the file license.mlic and presses Compatibility files in the
bar, then one will arrive in the directory, C:\Users\'User'\AppData\Local
\VirtualStore\Program Files\Metrohm\MagIC Net\bin ('User' being the
abbreviation (UID) for the user logged in on the operating system). The file
license.mlic with the license codes for the standard licenses and the 5 newly
added licenses is to be found here, i.e. the additional licenses are stored in the
VirtualStore of the Windows user who was logged in on the PC at the time
the additional licenses were added, only.

On the server, the program recognizes all of the licenses; the operating system
adds the file license.mlic from the directory C:\Users\'User'\AppData\Local
\VirtualStore\Program Files\MagIC Net\bin to the detail list of the direc-
tory C:\Program Files\Metrohm\MagIC Net\bin.

For the Client/Server functionality of the database server, however, the file
license.mlic in the directory C:\Program Files\Metrohm\MagIC Net\bin is
relevant, and here only the basic license is listed. Therefore problems are to be
anticipated when adding additional clients (more than the 3 clients present in
the default settings).

http://technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx
http://technet.microsoft.com/en-us/magazine/2007.06.uac.aspx
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Remedy

￭ For new installations
To enter additional licenses, the program must be started as administrator
(position the mouse on the Program icon press down the right-hand mouse
button – select Run as administrator there). If one then adds the license
code for additional licenses in the usual way, then the file license.mlic in
the directory C:\Program Files\Metrohm\MagIC Net\bin will contain
both license codes.

￭ For existing installations
First of all, the file license.mlic in the directory C:\Users\'User'\AppData
\Local\VirtualStore\Program Files\Metrohm\MagIC Net\bin must be
deleted. This file must not be present in the VirtualStore of any user – a
check must be made to make sure of this, and any such files which may be
found must be deleted.
Afterwards, the program must be started as administrator (position the
mouse on the Program icon and click the right mouse button – select Run
as administrator). If one then adds the license code for additional licenses
in the usual way, then the file license.mlic in the directory C:\Program
Files\Metrohm\MagIC Net\bin will contain both license codes.

9 User rights for MagIC Net

In order that the logged in user be able to access all functions with
MagIC Net, the windows system administrator must ensure that the permis-
sions are set for the directories as listed below:

Directory Permission Group name or
user name

Database directory

Directory where the databases will be saved (…\Data)

Modify SYSTEM

User*

Backup directory

Directory where the backups will be stored (…\Backup)

Modify User*

%ALLUSERSPROFILE%\Application Data\Metrohm
(Windows 2000, Windows XP)**

Modify User*

%PROGRAMDATA%\Metrohm (Windows Vista, Win-
dows 7) **

Modify User*

Export directories

Directories where the exported files are to be saved.

Modify User*

PDF directories

Directories where the PDF files are to be saved.

Modify User*

Desktop Modify User*

%PROGRAMFILES%\Metrohm\MagIC Net Read Execute User*
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* User = name of the user who is logged in

** During installation of MagIC Net the permission Full Control is set for the following groups:
SYSTEM, Administrators, User, Guests, Main users.
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